Facebook, Youtube хаах /block/


Хөгжиж байгаа нийгэмтэйгээ хөл нийлүүлэн алхаж буй залуу хүмүүс фэйсбүүк, юүтүбэд хэтэрхий их цаг зарцуулж байгаан залхууралд хөтөлж байна гэсэн судалгаа гарсан байна. Залуу хүн ч гэлтгүй албан газар дээр фэйсбүүк, юүтүб үзээд цагаа дэмий өнгөрөөгөөд ажил алаад байна. Угаасаа хүний тархи дэмий балай юманд байнга л тэмүүлж байдаг хойно байсгээл фэйсбүүк орно дахиад орно, гарна, орно. Хөгжим сонсноо бас хажуугаар нь.

Бацаан байхдаа нэг удаа Амаржаргал гуайн эдийн засгийн лекцэнд сууж байлаа. Тэрээр хэлэхдээ та бүхэн албан байгууллага амжилттай яваа, ажил төрөл нь сайн яваа эсэхийг корридороор нь яваад л мэдэх боломжтой гэж билээ. Яаж вэ гэвэл хэрвээ корридороор алхаж явхад чинь хүмүүс элдэв хов жив яриад бөөгнөрөөд байвал тэр газрын ажил салан задгай гэсэн үг гэсэн юм. Ухаантай хэлсэн байгаа биз. Мэдээжийн хэрэг хийх ажил багасна гэдэг өөрөө сүйрэлд нэг алхам алхамаар ойртож байна гэсэн үг. Удирдагч хүн ажилчнаа загнаж дарамтлах биш байнгийн тогтмол ачаалалтай байхад анхаарал хандуулах хэрэгтэйн зүйн хэрэг. Үүнээс гадна байгууллагад зомби болсон нөхдүүд байдаг. Тэр нөхдүүд дэмий балай юмаар оролдож тэгэс ингэсгээд цаг нөхцөөж дэмий цалин авах сонирхолтой байнуу гэхээс ажлаа сайн хийе гэж бодохгүй. Ийм нөхдүүдээс салахийн тулд мөн ажлын бүтээмжийг сайжруулахийн тулд л компаний дүрэм журам гэсэн зүйл байдаг шүү дээ. Улсын их хурал хууль, дүрэм баталдаг шиг компани мөн ажилчдаа дүрэм журмаар л залдаг. Өөр нэг их хийгээд байх зүйл байхгүй. Зөв бодлого баримталж зөв хийх хэрэгтэй. Үнэндээ удирдана гэдэг чинь удирдахгүйгээр удирдахийг хэлнэ гэж Лаоз хэлсэн нь бий. Тэгэхээр дүрэм журманд харш зүйлсийг хаах, таслан зогсоох хэрэгтэй. Сошиал сайтуудруу ажлаасаа орно гэж ер нь юу байсийн.

A. Facebook, Youtube -г Mikrotik дээр L7 түвшинд хаах

block_facebook_l7

 

 

 

 

 

 

1. Mikrotik-н IP > Firewall дотор ороход L7 protocol гэж байгаа энэ дотор дээрхи шиг нэмнэ
^.+(facebook.com|youtube).*$

filter_Advanced

















2. IP > Firewall > Filter rules ороод Advanced дээр LAYER7 Protocol дээр Denied гэж үүсгэсэн access list зааж өгнө. 
Хэрвээ тодорхой хаягуудыг хаах гэж байгаа бол Src address list дээр subnet хаягаа нэмж өгөх боломжтой
filter_General

















3. IP > Firewall > Filter rules дотор General хэсэг chain хэсэг дээр Forward гэдгийг сонгож өгнө.
filter_actions

















4. IP > Firewall > Filter rules дотор Action хэсэг drop гэдгийг сонгоно.
blocked_sites

амжилттай болсон бол дараахь байдлаар харагдана. 
B.Facebook, Youtube -г HT Employee Monitor ашиглан хаах
Виндовс дээр суулгадаг энгийн программаар тодорхой шалтгааны улмаас цөөн хэдэн компьютерийг хаахад тухайн 
программ илүү тохиромжтой байдаг.
Untitled

 

 

 

 

 

 

 

C. Facebook, Youtube -г Mikrotik дээр хаах

1. Script

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

# Script to add Facebook DNS IP addresses

# Syed Jahanzaib / aacable@hotmail.com

# Script Source: N/A / GOOGLE : )

 

:log warning “Script Started … Adding Facebook DNS ip’s to address list name   facebook_dns_ips”

:foreach i in=[/ip dns cache find] do={

:local bNew “true”;

:local cacheName [/ip dns cache all get $i name] ;

:if ([:find $cacheName “facebook”] != 0) do={

:local tmpAddress [/ip dns cache get $i address] ;

:put $tmpAddress;

:if ( [/ip firewall address-list find ] = “”) do={

:log info (“added entry: $[/ip dns cache get $i name] IP $tmpAddress”);

/ip firewall address-list add address=$tmpAddress list=facebook_dns_ips comment=$cacheName;

} else={

:foreach j in=[/ip firewall address-list find ] do={

:if ( [/ip firewall address-list get $j address] = $tmpAddress ) do={

:set bNew “false”;

}

}

:if ( $bNew = “true” ) do={

:log info (“added entry: $[/ip dns cache get $i name] IP $tmpAddress”);

/ip firewall address-list add address=$tmpAddress list=facebook_dns_ips comment=$cacheName;

}

}

}

}

# FB DNS IP ADD Script Ended …

 2. Scheduler

5 минут тутамд ажиллана.

1

2

/system scheduler

add disabled=no interval=5m name=fb-script-run-schedule on-event=facebook-list policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=feb/11/2014 start-time=00:00:00

3. Filter rule

1

2

/ip firewall filter

add action=drop chain=forward comment=”Filter Rule to block FB adress LIST : )” disabled=no dst-address-list=facebook_dns_ips

Хаагдсан үедээ иймэрхүү харагдана.
fb-script-address

 

 

 

 

 

 

 

 

 

filter-rule

 

 

 

 

 

 

 

 

 

 

2 Responses to Facebook, Youtube хаах /block/

  1. haaj bolohgui l bgamdaa ingeed. ene license level hed yum bol?

    Like

  2. Goy medee bn taalagdlaa

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Эмзэгхэн дэлбээ

This WordPress.com site is the bee's knees

Delgeen.com

Бидний блог

Миний...

Бидний блог

The Weatherman

Бидний блог

Mонголчууд

Бидний блог

Free Writers' Club

Бидний блог

PEARL'S SPACE

НОМЫН УТГЫГ АРВАН ТОХОЙ ӨРГӨН ДЭЛГЭРҮҮЛЭХЭЭС ГАНЦ ТОХОЙ ГҮН МЭДЭХ НЬ ЧУХАЛ

Амьдрал гэгч...

Бидний блог

%d bloggers like this: